<DSW1>
conf t
int fa 1/7
desc ##HQ_CE_Connection##
no switchport
ip add 10.10.100.13 255.255.255.252
no shut
!
router ospf 1
net 10.10.100.13 0.0.0.0 area 0
!
<DSW2>
conf t
int fa 1/8
desc ##HQ_CE_Connection##
no switchport
ip add 10.10.100.17 255.255.255.252
no shut
!
router ospf 1
net 10.10.100.17 0.0.0.0 area 0
!
<HQ_CE>
conf t
int fa 0/0
desc ##DSW1_Connection##
ip add 10.10.100.14 255.255.255.252
no shut
!
int fa 0/1
desc ##DSW2_Connection##
ip add 10.10.100.18 255.255.255.252
no shut
!
int s 1/0
desc ##Branch_WAN_Connection##
encapsulation ppp
ip add 10.10.100.21 255.255.255.252
no shut
!
router ospf 1
router-id 4.4.4.4
net 10.10.100.14 0.0.0.0 area 0
net 10.10.100.18 0.0.0.0 area 0
net 10.10.100.21 0.0.0.0 area 1
!
<Branch>
conf t
int fa 0/0
desc ##Branch_Internal_NET##
ip add 10.10.200.254 255.255.255.0
no shut
!
int s 1/0
desc ##HQ_WAN_Connection##
encapsulation ppp
ip add 10.10.100.22 255.255.255.252
no shut
!
router ospf 1
router-id 5.5.5.5
net 10.10.200.254 0.0.0.0 area 1
net 10.10.100.22 0.0.0.0 area 1
!
access-list 10 permit 10.10.200.0 0.0.0.255
## PPP Authentication ##
- PPP는 WAN 구간의 Layer 2 Protocol 중 하나이다.
Cisco Router의 경우 기본적으로 Serial interface는
Cisco HDLC로 동작한다. 이 경우 만약 다른 밴더 장비와
Point-to-Point 연결을 하거나 인증 등의 기능을 요구하는
경우 PPP를 사용할 수 있다.
- PPP는 HDLC와 다르게 다음과 같은 옵션을 제공한다.
-
Authentication(인증)
-
Multilink
-
압축
-
암호화
-
Callback
-
………..
- PPP Authentication 방식은 다음과 같이 2가지 방식이 존재.
-
PAP(PPP Authentication Protocol)
=> 평문(Plain Text/Clear Text)인증
=> 2-way
-
CHAP(Chanllenge Handshakes Authentication Protocol)
=>Hash 방식 사용(MD5)
=> 3-way
- PPP인증이 설정된 상태에서 인증에 실패하는 경우 Line
Protocol이 down 상태이기 때문에 통신이 불가능하다!
==================================================================
[1. PAP(PPP Authentication Protocol)]
<HQ_CE>
conf t
username Branch password cisco123 (나한테 접속할 상대방의 아이디)
int s 1/0
shut
PPP authentication pap
no shut
!
<Branch>
conf t
int s1/0
shut
ppp pap sent-username Branch password cisco123 (상대방이 알고 있는 아이디를 보내야함)
no shut
!
==================================================================
[2. CHAP(Challenge Handshakes Authentication Protocol)]
<HQ_CE>
int s 1/0
shut
no ppp authentication pap
ppp authentication chap
no shut
!
<Branch>
int s 1/0
shut
no ppp pap sent-username Branch password cisco123
ppp chap hostname Branch
ppp chap password cisco123
no shut
!
->CHAP인증방식을 사용했을 경우 wireshark에서 캡쳐한 결과
==================================================================
** Radius 인증 서버와 연동하여 PPP인증 구성 ***
<HQ_C>
conf t
int s 1/0
shut
no ppp authentication chap
no shut
!
int lo 0
ip add 10.10.239.1 255.255.255.0
!
router ospf 1
net 10.10.239.1 0.0.0.0 area 0
!
<Branch>
conf t
int s 1/0
shut
no ppp chap hostname Branch
no ppp chap password cisco123
no shut
!
<HQ_C>
conf t
aaa new-model
radius-server host 10.10.250.4 key ccie321
ip radius source-interface loopback 0
aaa authentication ppp PPP_AUTH group radius
int s 1/0
shut
ppp authentication chap PPP_AUTH
no shut
<Branch>
conf t
int s1/0
shut
ppp chap hostname Branch
ppp chap password cisco123
no shut
!
'공부 > 서버운영관리' 카테고리의 다른 글
ICT보안실무_자식도메인 (0) | 2020.11.03 |
---|---|
ICT보안실무_FTP (0) | 2020.11.01 |
ICT보안실무_RADIUS (0) | 2020.11.01 |
ICT보안실무_AAA (0) | 2020.11.01 |
ICT보안실무_Sys_Log (0) | 2020.11.01 |
댓글